Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » Installation Support

Post new topic   Reply to topic
Mysql - changed config and now won't start (SOLVED)
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Jan 24, 2013 4:33 pm    Post subject: Mysql - changed config and now won't start (SOLVED) Reply with quote

I stopped mysql and then uncommented innodb. Now when I try to start I get the following:

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)

Here was the problem:

'innodb_log_arch_dir=/var/lib/mysql/'

fixed now

thanks
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Thu Jan 24, 2013 10:34 pm    Post subject: Reply with quote

You can also switch to MyISAM as the default storage engine instead of uncomment lines.
Just add in /etc/my.cnf

Code:
skip-innodb
default_storage_engine=MyISAM


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Jan 24, 2013 11:11 pm    Post subject: Reply with quote

thanks will take a look.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Sat Jan 26, 2013 12:49 pm    Post subject: Reply with quote

I need the transactional capability of INNODB for financial transactions.

thanks
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Wed Jan 30, 2013 6:41 pm    Post subject: Reply with quote

so is there a way to enable innodb without the dreaded mysql.sock error? Most of my databases require innodb.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Wed Jan 30, 2013 7:05 pm    Post subject: Reply with quote

If you want to enable innodb, the minimum option in /etc/my.cnf is "innodb_data_file_path =" e.g.
innodb_data_file_path = ibdata1
innodb_data_file_path = ibdata1:10M:autoextend
innodb_data_file_path = ibdata1:10M:autoextend:max:800M

Can you post your innodb settings?


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Wed Jan 30, 2013 7:48 pm    Post subject: Reply with quote

all I did was uncomment the innodb options in my.cnf. I did not modify them.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Wed Jan 30, 2013 8:03 pm    Post subject: Reply with quote

What /var/lib/mysql/yourserver.err says?

Also look at /etc/mysql/ examples (large, huge) and follow instructions.

Code:
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
# Set .._log_file_size to 25 % of buffer pool size


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Wed Jan 30, 2013 8:44 pm    Post subject: Reply with quote

I have no errors right now. As posted above, I fixed it. The problem was the error stated above:

'innodb_log_arch_dir=/var/lib/mysql/'

Once I commented that out, it worked. So, I gather from your response that if I had left that commented, then there would not have been a problem.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Wed Jan 30, 2013 8:58 pm    Post subject: Reply with quote

Well that my.cnf was from mysql-5.0.x days so ti might contain deprecated options as
innodb_log_arch_dir , I just try it and get

Code:
unknown variable 'innodb_log_arch_dir=/var/lib/mysql/'


I'll remove it in a feature update..

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » Installation Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional