Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » Installation Support

Post new topic   Reply to topic
No Ethernet after Upgrade
View previous topic :: View next topic  
Author Message
drussell
Junior Member


Joined: 09 Feb 2012
Posts: 9

PostPosted: Wed Jul 03, 2013 4:30 pm    Post subject: No Ethernet after Upgrade Reply with quote

I followed your instructions to upgrade using 2.0.4 native CD.

On restart, my ethernet adapter is not connecting to my DHCP service.

I'm also somewhat bewildered by the large number of .new files in the /etc and subfolders.

Am I correct in assuming that the method of "taking care of .new files" is to look at both files in each case and apply changes in the .new to the other file?


Dave Russell
Springfield PA USA
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Wed Jul 03, 2013 4:42 pm    Post subject: Reply with quote

Is your adapter properly recognized, what "ifconfig -a" says...
From which version did you upgrade?

The .new files need you attention in case something ain't working due to deprecated configuration mostly, no need to change anything if a service is working as it should...

You can diff files to see changes with
Code:
diff -Nupr /etc/somefile{,.new}


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
drussell
Junior Member


Joined: 09 Feb 2012
Posts: 9

PostPosted: Thu Jul 04, 2013 12:08 am    Post subject: Reply with quote

gerasimos_h wrote:
Is your adapter properly recognized,

what "ifconfig -a" says...

Apparently the adapter is not being recognized. It's an IBM EtherJet 10/100.

From which version did you upgrade?

1.6.6 Native

The .new files need you attention in case something ain't working due to deprecated configuration mostly, no need to change anything if a service is working as it should...

You can diff files to see changes with
Code:
diff -Nupr /etc/somefile{,.new}


gerasimos_h
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Thu Jul 04, 2013 7:17 am    Post subject: Reply with quote

Did you upgrade from CD image or from slapt-get?
If you upgrade from slapt-get you need to pay attention to many new packages between those two versions 1.6.6 -> 2.0.4...

Assuming tulip is our driver, see if driver is loaded for etherjet with
Code:
lsmod |grep tulip

if not do
Code:
modprobe tulip

restart network with
Code:
/etc/rc.d/rc.inet1 eth0_restart

or even
Code:
/etc/rc.d/rc.inet1


Check network and ifconfig

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
drussell
Junior Member


Joined: 09 Feb 2012
Posts: 9

PostPosted: Thu Jul 11, 2013 3:53 am    Post subject: Reply with quote

It appears that my problem is that my system is still trying to load kernel 3.2.20 even though it's no longer current.

On boot I get error messages from udev indicating that it cant find files
agpart.ko
i2c-core.ko and
mii.ko

in /lib/modules/3.2.20/drivers or /net

when I run lilo I get an error because my lilo.conf points to /etc/vmlinuz and I only have kernel folders with the version and options appended to the vmlinuz name.

lsmod generates no output since apparently no modules are loaded.
I booted off of the live CD to be sure that I was using lsmod correctly.

Trying to load tulip using modprobe didn't generated an error that a believe is due to the kernel differences.

Believe mii is the correct Ethernet driver based on the above error message and the lsmod listing after booting off of the live CD.

So is fixing this simply a matter of correcting the vmlinuz entry in lilo.conf?
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Thu Jul 11, 2013 6:07 am    Post subject: Reply with quote

Are new kernels installed and available in /boot/ and /lib/modules?
If not try reinstall kernel-generic-smp and kernel-firmware (just in case) and look at /etc/lilo.conf to see which kernels are to boot.
You can also check the symlink in boot
ls -l /boot/vmlinuz

and when you are done run "lilo"

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
drussell
Junior Member


Joined: 09 Feb 2012
Posts: 9

PostPosted: Fri Jul 12, 2013 5:03 pm    Post subject: Reply with quote

Well I really fouled it up this time.

Tried copying one of the newer kernel files to vmlinuz

On reboot, system reports that the kernel file overlaps stage 2 of lilo.

This system is a multi partition Win98 Win2000 machine
You had previously helped me set this up on 22 Sep 2012.

So I booted into Windows which still works.

Somehow, the new linux kernel files got onto my Windows 98 partition.

Booted up on a GParted disk and the only kernel files on my linux partition are the 3.2.20 version.

Not sure how things got to where they are but I'm going to take the time to back up key files on the Windows partitions before continuing.

At this point I think it's probably best to give up on the upgrade and re-install 2.0.4.

Before I do that, however, I'll boot up on the newest live CD to verify that my hardware is supported.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1738
Location: Greece

PostPosted: Fri Jul 12, 2013 7:03 pm    Post subject: Reply with quote

Well certainly there is no need to reinstall, but to help you further more, I need to look into the system, even from livecd boot...
If you can give me SSH access (PM me or email) I can tell you what the big deal is...

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
drussell
Junior Member


Joined: 09 Feb 2012
Posts: 9

PostPosted: Mon Jul 15, 2013 1:15 am    Post subject: Reply with quote

Thank you for your attempts to assist.

I've decided to stop wasting your time and mine and have installed SMS 2.0.4 from the Native CD to another hard disk that I could dedicate to the service.

Systems running remarkably well. Am writing this from Konquror on the SMS system.

Thanks again.

Dave Russell
Springfield PA USA
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » Installation Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional