Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
Autodl-irssi
View previous topic :: View next topic  
Author Message
yumcake
Member


Joined: 31 Oct 2012
Posts: 44

PostPosted: Sat Nov 24, 2012 9:42 pm    Post subject: Autodl-irssi Reply with quote

The script located here does not function properly. What needs to be done to this script, or to the files it extracts, to make it function properly? The options that are said to pop up do not do so.

Also, and real benefit in upgrading the kernal for me? And, is there anything I can do to maximize harddrive space, removing things I do not need easily without damaging my current setup.

EDIT: Ok, I have it settled down a bit- I need these dependencies to run the script, which I cannot find on the repository in sms or on the main slackware packages list- libarchive-zip-perl libnet-ssleay-perl libhtml-parser-perl libxml-libxml-perl libdigest-sha1-perl libjson-perl libjson-xs-perl libxml-libxslt-perl

EDIT2: Alright, so I found a new script, http://tbsf.me/scripts/autodl-setup.sh which runs fine until it runs into a cpan dependency problem...

Code:
Result: PASS
  MAKAMAKA/JSON-2.53.tar.gz
Tests succeeded but one dependency not OK (JSON::XS)
  MAKAMAKA/JSON-2.53.tar.gz
  [dependencies] -- NA
Running make install
  make test had returned bad status, won't install without force

***ERROR***
CPAN somehow failed to install the missing Perl modules. Missing: XML::NamespaceSupport XML::SAX JSON::XS  XML::LibXML JSON
***ERROR***


EDIT3:
More info here, http://sourceforge.net/projects/autodl-irssi/
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Sun Nov 25, 2012 7:37 am    Post subject: Reply with quote

I take a quick look at your second script, and it tries to install rtorrent, webmin and other stuff.
If you want only the plugin, install the plugin only.


Perl module JSON::XS is available in otrs-perl package you can try to slapt-get it.

I'll take a proper look of the script later today...

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
yumcake
Member


Joined: 31 Oct 2012
Posts: 44

PostPosted: Sun Nov 25, 2012 3:48 pm    Post subject: Reply with quote

gerasimos_h wrote:
I take a quick look at your second script, and it tries to install rtorrent, webmin and other stuff.
If you want only the plugin, install the plugin only.


Perl module JSON::XS is available in otrs-perl package you can try to slapt-get it.

I'll take a proper look of the script later today...

gerasimos_h


Right, when you run it it, you can run it with flags to negate the installation if rtorrent, webmin, etc. If you don't use it with flags, it actually walks you through what you want to install. So either way you can avoid it, the benefit it had over the other was that it tried to cpan dependencies.
Back to top
View user's profile Send private message
yumcake
Member


Joined: 31 Oct 2012
Posts: 44

PostPosted: Sun Nov 25, 2012 5:10 pm    Post subject: Reply with quote

Here is the output of the first (simpler) sh on the screen it leaves hanging.
Code:
root@serv:~# screen -r 21888

          /usr/share/irssi/scripts /usr/lib/perl5 /usr/lib/perl5/vendor_perl .)
          at /root/.irssi/scripts/AutodlIrssi/XmlParser.pm line 35.
09:03 BEGIN failed--compilation aborted at
          /root/.irssi/scripts/AutodlIrssi/XmlParser.pm line 35.
09:03 Compilation failed in require at
          /root/.irssi/scripts/AutodlIrssi/TrackerXmlParser.pm line 35.
09:03 BEGIN failed--compilation aborted at
          /root/.irssi/scripts/AutodlIrssi/TrackerXmlParser.pm line 35.
09:03 Compilation failed in require at
          /root/.irssi/scripts/AutodlIrssi/TrackerManager.pm line 35.
09:03 BEGIN failed--compilation aborted at
          /root/.irssi/scripts/AutodlIrssi/TrackerManager.pm line 35.
09:03 Compilation failed in require at
          /root/.irssi/scripts/AutodlIrssi/Startup.pm line 39.
09:03 BEGIN failed--compilation aborted at
          /root/.irssi/scripts/AutodlIrssi/Startup.pm line 39.
09:03 Compilation failed in require at
          /root/.irssi/scripts/autorun/autodl-irssi.pl line 76.
09:03 BEGIN failed--compilation aborted at
          /root/.irssi/scripts/autorun/autodl-irssi.pl line 76.
09:03
 [09:04] [] [1]
[(status)]


On the more complex one, it claims...
Code:
***ERROR***
CPAN somehow failed to install the missing Perl modules. Missing: XML::NamespaceSupport XML::SAX  XML::LibXML
***ERROR***


Yet I know that cannot be true, because I manually cpan'd two that are left

Code:
root@serv:~# cpan XML::NamespaceSupport
Reading '/root/.cpan/Metadata'
  Database was generated on Sun, 18 Nov 2012 10:55:04 GMT
XML::NamespaceSupport is up to date (1.11).
root@serv:~# cpan XML::SAX
Reading '/root/.cpan/Metadata'
  Database was generated on Sun, 18 Nov 2012 10:55:04 GMT
XML::SAX is up to date (0.99).


Those XML::LibXML does fail.

Code:
root@serv:~# cpan XML::LibXML
Reading '/root/.cpan/Metadata'
  Database was generated on Sun, 18 Nov 2012 10:55:04 GMT
Running install for module 'XML::LibXML'
Running make for S/SH/SHLOMIF/XML-LibXML-2.0012.tar.gz
Checksum for /root/.cpan/sources/authors/id/S/SH/SHLOMIF/XML-LibXML-2.0012.tar.gz ok

  CPAN.pm: Building S/SH/SHLOMIF/XML-LibXML-2.0012.tar.gz

enable native perl UTF8
running xml2-config...ok (2.8.0)
Checking for ability to link against xml2...no
Checking for ability to link against libxml2...libxml2, zlib, and/or the Math library (-lm) have not been found.
Try setting LIBS and INC values on the command line
Or get libxml2 from
  http://xmlsoft.org/
If you install via RPMs, make sure you also install the -devel
RPMs, as this is where the headers (.h files) are.

Also, you may try to run perl Makefile.PL with the DEBUG=1 parameter
to see the exact reason why the detection of libxml2 installation
failed or why Makefile.PL was not able to compile a test program.
No 'Makefile' created'YAML' not installed, will not store persistent state
  SHLOMIF/XML-LibXML-2.0012.tar.gz
  /usr/bin/perl5.16.2 Makefile.PL -- NOT OK
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install
Could not read metadata file. Falling back to other methods to determine prerequisites

Then it just goes back to cl
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Mon Nov 26, 2012 9:54 am    Post subject: Reply with quote

I don't know if anyone had installed autdl-irssi from that script, only by looking at it, it gives me headaches Smile
I install it manually anyway.

I've been quite busy past weekend but I manage to create a package.
Hopefully you ain't need to do anything more than restarting apache.

Package includes json php extension and perl modules JSON JSON::XS XML::LIBXML
also I have create a startup script for irssi, to start it do
/etc/rc.d/rc.irssi start
Same as rtorrent, irssi runs as user administrator.

I have set options in autodl-irssi
port=9999
password=admin

if you want to change the above edit files
/var/www/htdocs/rutorrent/plugins/autodl-irssi/conf.php
/home/administrator/.autodl/autodl.cfg


gerasimos_h



autodl-irssi-1.31-noarch-1sms.txz
 Description:
autodl-irssi

Download
 Filename:  autodl-irssi-1.31-noarch-1sms.txz
 Filesize:  676.78 KB
 Downloaded:  772 Time(s)


_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
yumcake
Member


Joined: 31 Oct 2012
Posts: 44

PostPosted: Mon Nov 26, 2012 5:23 pm    Post subject: Reply with quote

gerasimos_h wrote:
I don't know if anyone had installed autdl-irssi from that script, only by looking at it, it gives me headaches Smile
I install it manually anyway.

I've been quite busy past weekend but I manage to create a package.
Hopefully you ain't need to do anything more than restarting apache.

Package includes json php extension and perl modules JSON JSON::XS XML::LIBXML
also I have create a startup script for irssi, to start it do
/etc/rc.d/rc.irssi start
Same as rtorrent, irssi runs as user administrator.

I have set options in autodl-irssi
port=9999
password=admin

if you want to change the above edit files
/var/www/htdocs/rutorrent/plugins/autodl-irssi/conf.php
/home/administrator/.autodl/autodl.cfg


gerasimos_h


Does this install the rutorrent plugin as well?

EDIT: Of course it does, woo thank you! Much much love!


Last edited by yumcake on Mon Nov 26, 2012 5:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Mon Nov 26, 2012 5:36 pm    Post subject: Reply with quote

Yes, after restarting apache you should see the plugin in rutorrent .
I'll add it at repository also, unless you found a bug Smile

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional