Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » Installation Support

Post new topic   Reply to topic
SIOCSIFADDR: No such device eth0
View previous topic :: View next topic  
Author Message
roberto
Junior Member


Joined: 23 Nov 2007
Posts: 5
Location: italy

PostPosted: Sun Nov 25, 2007 11:13 pm    Post subject: SIOCSIFADDR: No such device eth0 Reply with quote

I've just installed sms ...I've confugurated the network with netconfig
ip 192.168.1.6
gw 192.168.1.1
host linux
dm casa
nameserver 192.168.1.1

I can exit on internet , but I can't undestand what's happen with ethernet
I have only (eth0)one on my pc

if I do

root@sms:~# ifconfig eth0 192.168.1.6 up
eth0: ERROR while getting interface flags: No such device

then

root@sms:~# modprobe eth0
FATAL:Module eth0 not found.

then

root@sms:~# dmesg | grep eth0
AMDtek Comet rev 17 at MMIO 0xdd000000, 00:04:5A:6E:85:f4, irq 11


and

root@sms:~# lspci -v
........
00:0c.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
Subsystem: ADMtek Unknown device 0574
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at e800 [size=256]
Memory at dd000000 (32-bit, non-prefetchable) [size=1K]
[virtual] Expansion ROM at 30000000 [disabled] [size=128K]
Capabilities: [c0] Power Management version 2


# so I think it' works

root@sms:~# ifconfig
eth1 Link encap:Ethernet HWaddr 00:04:5A:6E:85:F4
inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::204:5aff:fe6e:85f4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:394 errors:0 dropped:0 overruns:0 frame:0
TX packets:245 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:44169 (43.1 KiB) TX bytes:160788 (157.0 KiB)
Interrupt:11 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5713 errors:0 dropped:0 overruns:0 frame:0
TX packets:5713 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:767499 (749.5 KiB) TX bytes:767499 (749.5 KiB)


#really strange


so I' ve tried

root@sms:~# dmesg | grep eth1
eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
eth1: no IPv6 routers present
eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
eth1: no IPv6 routers present
eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
eth1: no IPv6 routers present


this is a part of

# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other
# settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]="192.168.1.6"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
------------------------------

ecceteraeccetera....



Anybody had the some problem?
Roberto
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Mon Nov 26, 2007 7:08 am    Post subject: Reply with quote

That was/is a common bug in SMS. Skips eth0 and assign eth1 or eth2.
I though I had fix that but I'll check it out again.
Other than that you should be able to have connectivity on eth1.
what your /etc/resolv.conf and /etc/resolv.conf-eth0.sv says?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Mon Nov 26, 2007 9:13 am    Post subject: Reply with quote

OK! I found it..
edit
/etc/udev/rules.d/75-network-devices.rules
and remove my entry of eth0 and put yours, or remove all of them, udev will re-write the entries.
you can additionally remove "rm /etc/dhcpcd/*eth*"
and restart you PC, that should fix eth0 problem.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Mon Nov 26, 2007 10:00 pm    Post subject: Reply with quote

Hey that is great! I'm glad you found the problem. Now I can change the servers to accept eth0.

AAAh ain't life grand
Back to top
View user's profile Send private message
roberto
Junior Member


Joined: 23 Nov 2007
Posts: 5
Location: italy

PostPosted: Tue Nov 27, 2007 10:59 am    Post subject: Reply with quote

Thanks....now I can see my eth0
bye Roberto
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » Installation Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional