Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » Installation Support

Post new topic   Reply to topic
setting up network and hostname
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Nov 22, 2007 6:35 pm    Post subject: setting up network and hostname Reply with quote

I've installed SMS 1.3 on four servers now. Really like the features of 1.3.

I've noticed a problem from the first time I have installed sms. If you use netconfig to setup hostname and network parameters, it sets the hostname and ip but on eth0. Which means you can not connect to network. eth0 seems to be reserved for DHCP connections.

So, you have to manually edit /etc/rc.d/rc.inet1.conf and move ip from eth0 to eth1. Then logout and everything is correct. This seems to make netconfig moot for setup.

I suspect this is a slackware issue and not really a sms issue.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Thu Nov 22, 2007 7:09 pm    Post subject: Reply with quote

eth0 by default has
USE_DHCP[0]="yes"
but if you use netconfig and choose "static IP" then you will have
USE_DHCP[0]=""
Have you try restarting your server and got no traffic on eth0 or eth0 was down?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Fri Nov 23, 2007 12:35 am    Post subject: Reply with quote

When you choose static ip in netconfig, it writes the ip to eth0. I know this by looking at /etc/rc.d/rc.inet1.conf.

Upon restarting network services there is no connectivity. All setings in /etc/hosts, /etc/HOSTNAME, and /etc/resolv.conf are correct. But no connectivity.

If I change the ip to eth1, then I have connectivity. This happens on every system that I install on with netconfig.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Nov 23, 2007 8:33 am    Post subject: Reply with quote

there is also /etc/resolv.conf-eth0.sv
I'm surprised cause I'm using eth0 on all my slackware systems including SMS.
Try "ifconfig eth0 down"
then "netconfig" or edit your /etc/rc.d/inet1.conf
do a
"/etc/rc.d/rc.inetd restart && /etc/rc.d/rc.inet1 && /etc/rc.d/rc.inet2"
and if you type 'ifconfig" you should have your eth0 configuration up and working with your new settings.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » Installation Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional