Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
vsftp not sending welcome message? Goto page 1, 2  Next
View previous topic :: View next topic  
Author Message
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Thu Feb 23, 2012 4:44 pm    Post subject: vsftp not sending welcome message? Reply with quote

Hi

I have my server running with DYNDNS but if I use FileZilla to access the server via FTP and using the DYNDNS address, the program hangs as it is waiting for a welcome message. If I test using the internal address "sms", everything runs smoothly but the welcome message is not the message I have set up in the vsftp config file?

Any hints would help a lot as I am trying to set up my server as a dropbox for my family utilizing the Open Source program FTPbox

Thanks a lot
Riteman
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Thu Feb 23, 2012 5:39 pm    Post subject: Reply with quote

Do you have a variable ftpd_banner uncomment in /etc/vsftpd.conf?
default is
ftpd_banner= Welcome to blah FTP service.

did you restart /etc/rc.d/rc.inetd after editing?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Thu Feb 23, 2012 5:55 pm    Post subject: Reply with quote

I have uncommented and modified the banner message and restarted the FTP server
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Thu Feb 23, 2012 6:16 pm    Post subject: Reply with quote

Are you sure, you didn't see welcome message in log files of your ftp client?
Try from bash by typing
ftp 127.0.0.1
Does your welcome message appear?
you should see something like

Code:
root@sms:~# ftp 127.0.0.1
Connected to 127.0.0.1.
220  Welcome to blah FTP service.
Name (127.0.0.1:root):


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Thu Feb 23, 2012 11:17 pm    Post subject: Reply with quote

when I look into the exchange of commands between FTPclient and server when accessing inside my network it states

220 SMS FTP Server

which is not the string I have in the conf-file
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 7:33 am    Post subject: Reply with quote

You need to stop proftpd first, as you have 2 FTP servers running.
to stop proftpd run
/etc/rc.d/rc.proftpd stop
and disable service with
chmod -x /etc/rc.d/rc.proftpd

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 11:36 am    Post subject: Reply with quote

Thanks

I did what you suggested and as result got "stopping proftpd..", then I used the chmod command and now I cannot log in via FTP at all: The message now is "Connection established waiting for welcome message" also when I log in from within my own network
If I run "ftp sms" from a commandwindow on my windows-PC I get "connected to sms.fritz.box" followed by "Connection closed by remote host"
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 11:43 am    Post subject: Reply with quote

Have you enable vsftpd through /etc/inetd.conf as described in wiki?
Code:
# Very Secure File Transfer Protocol (FTP) server.
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  vsftpd


It sound like you were using proftpd and not vsftpd.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 11:54 am    Post subject: Reply with quote

thanks again - peeople reading the Wiki sure have an advantage
I enabled and using "ftpuser" "ftpuser" I get the error "530 Login incorrect." ?
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 12:00 pm    Post subject: Reply with quote

riteman wrote:

I enabled and using "ftpuser" "ftpuser" I get the error "530 Login incorrect." ?


That's normal since that login details refer to proftpd configuration.
There is a section at wiki for vsftpd you might wanna look on how to configure.
http://sms.it-ccs.com/wiki/#LinkTarget_1476

by default vsftpd allow anonymous login so you should be able to login anonymously,

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 12:09 pm    Post subject: Reply with quote

..strange as the first entry in the conf file says:
ftp_username=ftpuser
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 12:19 pm    Post subject: Reply with quote

This is from man pages
Code:
ftp_username
              This  is the name of the user we use for handling anonymous FTP. The home directory of this user is the root of the anonymous
              FTP area.

              Default: ftp


ftpuser has no home so path for anonymous is invalid.
If you are going to use vsftpd, either edit default ftp users (ftpuser,webftp) or delete them and add new ones, according to your needs.

Can you post your vsftpd.conf or what you are trying to set up, like paths and users?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 1:11 pm    Post subject: Reply with quote

attached my conf file: I now can log into the FTP server from within my network - as soon as I try to login using the dyndns address it resolves the IP address correctly but stops waiting for the welcome message
Changed ftpuser to have a homedir



vsftpd.txt
 Description:

Download
 Filename:  vsftpd.txt
 Filesize:  4.49 KB
 Downloaded:  703 Time(s)

Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 1:21 pm    Post subject: Reply with quote

Your config looks OK...
Have you set up port forward on your router, to forward ports 20-21 to your local machine?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 1:22 pm    Post subject: Reply with quote

only port 21
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional