Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
php config
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Mon Jun 28, 2010 5:00 am    Post subject: php config Reply with quote

I am installing a php based helpdesk. When I access the setup I get this msg:

The GD extension needs to be enabled in your PHP.INI file in order for Eventum to work properly. The MySQL extension needs to be enabled in your PHP.INI file in order for Eventum to work properly. The Multibyte String Functions extension is not enabled in your PHP installation. For localization to work properly you need to install this extension. If you do not install this extension localization will be disabled.

I believe from what I can tell, they are enabled.

What is very strange is that on another server running 1.5.2. as is the above server, I installed the same app without any errors. My production server is the one giving the error msg. Any ideas what could be wrong?

my /var/log/httpd/error_log gives this.

[Sun Jun 27 19:59:48 2010] [error] [client 192.168.1.161] File does not exist: /srv/httpd/htdocs/favicon.ico
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Mon Jun 28, 2010 5:55 am    Post subject: annotation Reply with quote

also in my httpd/error_log:

PHP: syntax error, unexpected TC_STRING in /etc/httpd/php.ini on line 107

also on reboot:'warning php-url-fopen action not defined
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Mon Jun 28, 2010 6:11 am    Post subject: SOLVED Reply with quote

okay I have php.ini working correctly now.

I still have the error msg:

also on reboot:'warning php-url-fopen action not defined
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Mon Jun 28, 2010 6:53 am    Post subject: Reply with quote

you enable php-url-fopen filter in fail2ban but you don't have an action, so it loads default.
You can edit /etc/fail2ban/jail.conf and add in
[php-url-fopen]

action = iptables-multiport[name=BadBots, port="http,https"]
sendmail[name=php_url_open, dest=root@localhost]

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Mon Jun 28, 2010 3:58 pm    Post subject: Reply with quote

thanks for the direction. Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional