Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
problems with egroupware in 1.3.6 and 1.3.7
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Sun May 04, 2008 4:53 am    Post subject: problems with egroupware in 1.3.6 and 1.3.7 Reply with quote

I have installed 1.3.6. and 1.3.7 native cd. I have made no changes to them. When logging into egroupware setup, I choose config. Then I choose to create an admin account. It lets me save the account but then gives me this message:

ldap_add(,uid=baboo,ou=accounts,o=egroupware,dc=sms,dc=org,Array ( [objectclass] => Array ( [0] => top [1] => person [2] => organizationalperson [3] => inetorgperson [4] => posixaccount [5] => shadowaccount ) [uidnumber] => 1006 [uid] => baboo [gidnumber] => 1003 [sn] => [cn] => [userpassword] => {SSHA}98hEClMzWvF1qcjXZ5WZ0AUbE595M1hjdUJRQw== [homedirectory] => /dev/null ) ) Invalid syntax

Error in admin-creation !!!

It does it in both versions. I think there is a problem.

BTW, if I use konqueror when I try to create admin account it logs me out of egroupware setup. This does not happen when you use firefox.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Sun May 04, 2008 11:36 am    Post subject: Reply with quote

Did you install it from SMS.NativeCD menu, or you install it later as a package manual?
I did found some issues when installing from the slackware installer during SMS.NativeCD installation, but there are no problems if you install it manual later as a package with the command 'installpkg'.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Sun May 04, 2008 2:35 pm    Post subject: Reply with quote

yes, it was from slackware menu. However, I did install 1.4.04 manually on 1.3.7 and had the same problem.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Sun May 04, 2008 4:25 pm    Post subject: Reply with quote

The following error message comes from 1.3.6 native cd. I removed the installed egroupware that was from slackware menu and then installed egroupware pkg.

ldap_add(,uid=baboo,ou=accounts,o=egroupware,dc=sms,dc=org,Array ( [objectclass] => Array ( [0] => top [1] => person [2] => organizationalperson [3] => inetorgperson [4] => posixaccount [5] => shadowaccount ) [uidnumber] => 1005 [uid] => baboo [gidnumber] => 1003 [sn] => [cn] => [userpassword] => {SSHA}ToKX2J/wMjRmu7FN+h9LR4dBlw1MaUR0YjhlSQ== [homedirectory] => /dev/null ) ) Invalid syntax

Error in admin-creation !!!
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Sun May 04, 2008 5:15 pm    Post subject: Reply with quote

Have you have a login info to your site, egroupware package should working, works for me anyway...
Just boot from liveCD, in live mode install egroupware and go to http://sms/egroupware/setup, and setup admin account, account is created.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Sun May 04, 2008 8:38 pm    Post subject: Reply with quote

I'm sorry but my site is not online yet. I've tried everything you suggested, on four different servers, and I get this same message:

ldap_add(,uid=baboo,ou=accounts,o=egroupware,dc=sms,dc=org,Array ( [objectclass] => Array ( [0] => top [1] => person [2] => organizationalperson [3] => inetorgperson [4] => posixaccount [5] => shadowaccount ) [uidnumber] => 1007 [uid] => baboo [gidnumber] => 1003 [sn] => [cn] => [userpassword] => {SSHA}e98ldpzzTpgPtv+WUwvbhP+9noNTRjR0aFo1Qw== [homedirectory] => /dev/null ) ) Invalid syntax

Error in admin-creation !!!

I don't know why it works for you but not me. I posted out into the general discussion area hoping others would share their experiences so we could figure out if me or some other problem. But alas, to no avail.

I need to bring my site up so for now I am going to use a different server and keep working on this problem. When I get it solved, I will switch back to SMS. Maybe I will wait for your 1.3.8 release now that slackware has released stable version.

thanks for the help
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Sun May 04, 2008 9:11 pm    Post subject: Reply with quote

I'm really sorry.
Have you try what I tell you to do with SMS-1.3.7?
No need to install anything, no fear of loosing anything, 5-10 minutes of your time.

1. boot SMS.LiveCD-1.3.7.
2. install egroupware package (egroupware-1.4.002-1sms.tgz)
3. go to http://sms/egroupware/setup
4. login with admin.admin @ Setup/Config Admin Login
5. create admin account
6. login to http://sms/egroupware and create users

it's working for me, minor issues with mail might occurred since I've change a lot in SMS mail server , but those can be fixed quite easily.
I'll create an egroupware-1.4.004 package for SMS-1.3.8 anyway.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Sun May 04, 2008 10:32 pm    Post subject: Reply with quote

nothing for you to be sorry about. We will figure it out eventually. I've tried what you are suggesting on two different boxes. I get the same above message every time.

I am building a new box and will install 1.3.8 on it. Then try to figure out what is going on.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu May 15, 2008 3:37 pm    Post subject: possible identification of problem Reply with quote

I have done quite a bit of discovery about this problem with egroupware and ldap not binding and giving syntax errors. It appears quite a few egroupware users have complained about the exact same thing. What egroupware developers say is that posix_group has a problem with memberuid being empty. There is a script to modifiy class_accounts_ldap in egroupware phpgwapi config file. However, it does not work for me.

Here is the problem in a simple recount. When ldap and egroupware are configured, if you leave the step 3 in egroupware empty (creating an admin account), then when some one tries to do that upon installation, egroupware sees it as an error.

If you want to preconfigure sms for ldap and egroupware integration, I suggest that you create an admin account called admin or whatever, and then people will be able to change it. So, a new install a user could change data from sms to whatever they want to call there domain or server and then go into egroupware config; make changes and create a new admin user. This should work.

As always your thoughts are appreciated.

BTW, looking forward to nativecd 1.3.8 release.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional