Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
printer problem
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Apr 08, 2008 6:16 pm    Post subject: printer problem Reply with quote

I connected HP printer to sever via usb. Cups says its there but when I try to print test page I get this error msg:

"/usr/lib/cups/filter/foomatic-rip failed"

I need a little help from my friends - I couldn't resist Very Happy
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Apr 08, 2008 6:51 pm    Post subject: Reply with quote

I just ran hp-setup and selected usb. then it told me no devices fouind. Odd, because cups automatically found it.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Apr 08, 2008 7:02 pm    Post subject: Reply with quote

in hp-setup I selected manually find device. It asks for device ID. I tried to enter number but it won't let me.

Forgive me Gerasimos, but do we have a bug here? Smile
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Apr 08, 2008 7:05 pm    Post subject: Reply with quote

I am wondering if the 'ghostscript file' is corrupted.

Just a thought.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Apr 08, 2008 7:15 pm    Post subject: Reply with quote

here is output when I tried to test print.


root@nemo:~/install# tail -f /var/log/cups/error_log
D [08/Apr/2008:11:13:52 -0600] write_file: 13 file=7
D [08/Apr/2008:11:13:52 -0600] cupsdAcceptClient: 7 from nemo.cliqn.com:631 (IPv4)
D [08/Apr/2008:11:13:52 -0600] encrypt_client: 7 Connection from nemo.cliqn.com now encrypted.
D [08/Apr/2008:11:13:53 -0600] cupsdReadClient: 7 GET /images/button-move-job.gif HTTP/1.1
D [08/Apr/2008:11:13:53 -0600] cupsdReadClient: 7 Browser asked for language "en.utf-8"...
D [08/Apr/2008:11:13:53 -0600] cupsdAuthorize: username="root"
D [08/Apr/2008:11:13:53 -0600] write_file: 7 file=14
D [08/Apr/2008:11:13:55 -0600] cupsdCloseClient: 9
D [08/Apr/2008:11:13:55 -0600] cupsdCloseClient: 12
D [08/Apr/2008:11:13:55 -0600] cupsdCloseClient: 11
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Apr 08, 2008 7:46 pm    Post subject: SOLVED Reply with quote

okay - lot's of research found the answer.

Issue 4: The "/dev/usb/lp0" device node is deleted after using HPLIP.


The "/dev/usb/lp0" device node is created by usblp. HPLIP does not use usblp, instead HPLIP uses libusb. Libusb uses the "/dev/bus/usb/xxx/xxx" device node instead of the "/dev/usb/lp0" device node.


Since usblp and libusb cannot claim the the same usb device, any HPLIP device I/O usage (ie: scanning, printing or faxing) will remove usblp from the "/dev/usb/lp0" device node. Once usblp has been removed from the device node, the device node is deleted and cannot be restored except by another UDEV plug-n-play event.


If you are using CUPS this means in general you should always use the HPLIP's "hp" backend (ie: "hp:/usb/...") instead of the standard CUPS "usb" backend (ie: "usb://...").

The "hp" backend will always use the libusb device node. If you try to use the "usb" backend the "/dev/usb/lp0" device node may not be available.

So, anyone using an hp printer that also prints photos will have this problem. here is how the uri would look:

hp:/usb/Photosmart_C5200_series?serial=MY776CG1BT04XQ

My other p-rinters have no problems. The things I do for my wife.

Sorry Gerasimos, for using the bug word Embarassed
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Tue Apr 08, 2008 9:25 pm    Post subject: Reply with quote

Well cups should recognize hp socket if you have started /etc/rc.d/rc.hplip.
I just take a look at SMS-1.3.7 (no X) and notice that foomatic failed, I'll check on that.
I don't believe that SMS it's a bug free distro, so don't worry Smile

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Apr 10, 2008 1:26 am    Post subject: Reply with quote

Even though I got the printer to work, I tried to start '/etc/rc.d/rc.hplip'.

I get a Permission denied msg.

Is something wrong?
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Thu Apr 10, 2008 6:09 am    Post subject: Reply with quote

What are the permissions. Try to make it executable with
chmod +x /etc/rc.d/rc.hplip

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Thu Apr 10, 2008 6:09 am    Post subject: Reply with quote

What are the permissions?
Try to make it executable with
chmod +x /etc/rc.d/rc.hplip

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Apr 10, 2008 1:52 pm    Post subject: Reply with quote

changing the permissions worked for starting the script. But it fails with this msg:

Starting hpiod:
Starting hpssd:
HP Linux Imaging and Printing System (ver. 1.7.4a)
Services and Status Daemon ver. 9.1

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

can't lock /var/run/hpssd.pid, running daemon's pid may be 3544
[FAILED]
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Thu Apr 10, 2008 5:17 pm    Post subject: Reply with quote

try to delete /var/run/hpssd.pid

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Apr 10, 2008 5:39 pm    Post subject: Reply with quote

that worked!

I sure wish I knew all this crap. Sad

thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional