Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » Bugs

Post new topic   Reply to topic
MailScanner erroir
View previous topic :: View next topic  
Author Message
Busta
-{ D.O.N.A.T.O.R. }-


Joined: 13 Aug 2007
Posts: 81

PostPosted: Tue Feb 19, 2008 1:17 am    Post subject: MailScanner erroir Reply with quote

Feb 18 17:11:12 sms MailScanner[6089]: New Batch: Scanning 1 messages, 5235 bytes
Feb 18 17:11:25 sms MailScanner[6089]: Spam Checks: Found 1 spam messages
Feb 18 17:11:25 sms MailScanner[6089]: Virus and Content Scanning: Starting
Feb 18 17:11:25 sms MailScanner[6089]: ERROR: Unable to open file or directory
Feb 18 17:11:25 sms MailScanner[6089]: Requeue: 6A85C124A8.1B0A4 to 63EF7124C6

This happens whether there is an attachment or not to the email message. I did check the perms on the working / incoming folders and they are all owned by "postfix" . Which should be corrct.
I have not modified the MailScanner config or Calmav config from default.
Any idea why this error from MailScanner? - thx's
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue Feb 19, 2008 4:07 am    Post subject: Reply with quote

I can't tell you why you are getting those messages, but I can tell you I am running sms out of the box for four hundred users with no problems. Since October.

At first I had alot of configuration problems but in every single case it was my mistake and not sms.

So, just hang in there because gerasimos will definitely help you solve it.

regards
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1742
Location: Greece

PostPosted: Tue Feb 19, 2008 12:38 pm    Post subject: Reply with quote

Well I tried to replicate your error but I couldn't do it..
I found though some things to fix in SMS-1.3.7
Squirrelmail config.php
forgot to alter
$attachment_dir = '/var/local/squirrelmail/attach/';
to
$attachment_dir = '/var/squirrelmail/attach/';
couldn't attach files
rc.spamd
SNAME=rc.spamassassin
to
SNAME=rc.spamd
couldn't restart
MailScanner.conf
SpamAssassin Local Rules Dir = /opt/MailScanner/etc/mail/spamassassin
to
SpamAssassin Local Rules Dir = /etc/mail/spamassassin
no error but wasn't right.

What else errors are in /var/log/maillog?
Set /opt/Mailscanner/etc/MailScanner.conf to
Debug = yes
to output more about the error..

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1742
Location: Greece

PostPosted: Tue Feb 19, 2008 2:58 pm    Post subject: Reply with quote

Open MailScanner.conf and change

Clamd Socket = /tmp/clamd
to
clamd Socket = /var/run/clamav-milter/clamd.sock

Feb 19 14:51:27 sms MailScanner[7738]: New Batch: Scanning 1 messages, 2251 bytes
Feb 19 14:51:27 sms MailScanner[7738]: Virus and Content Scanning: Starting
Feb 19 14:51:27 sms MailScanner[7738]: Requeue: 5F24C2072.3BCFE to 0FDB42081
Feb 19 14:51:27 sms MailScanner[7738]: Uninfected: Delivered 1 messages


Thanks for pointing out.
gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Busta
-{ D.O.N.A.T.O.R. }-


Joined: 13 Aug 2007
Posts: 81

PostPosted: Wed Feb 20, 2008 5:20 pm    Post subject: Reply with quote

ok - that resolved the error.

Also geting this error in mail log;

postfix/smtpd[4400]: warning: connect to Milter service unix:/var/run/clamav-milter/milter.sock: Permission denied

I checked the milter.sock link and chmod 777 the link-

BEFORE
-rw-rw---- 1 clamav clamav 4 2008-02-20 08:53 clamd.pid
srwxrwxrwx 1 clamav clamav 0 2008-02-20 08:53 clamd.sock=
-rw-rw---- 1 clamav clamav 6 2008-02-20 08:53 milter.pid
srwxr-xr-x 1 clamav clamav 0 2008-02-20 08:53 milter.sock=

root@scan:/var/run/clamav-milter# chmod 777 milter.sock
root@scan:/var/run/clamav-milter# ls -l

AFTER
-rw-rw---- 1 clamav clamav 4 2008-02-20 08:53 clamd.pid
srwxrwxrwx 1 clamav clamav 0 2008-02-20 08:53 clamd.sock=
-rw-rw---- 1 clamav clamav 6 2008-02-20 08:53 milter.pid
srwxrwxrwx 1 clamav clamav 0 2008-02-20 08:53 milter.sock=

This resolved the permission error I was seeing in the logs

Thank you - I appreciate your assistance.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1742
Location: Greece

PostPosted: Wed Feb 20, 2008 8:07 pm    Post subject: Reply with quote

The default permission by default at SMS is

root@sms:~# ls -l /var/run/clamav-milter/milter.sock
srwxrwxrwx 1 clamav clamav 0 2008-02-20 20:05 /var/run/clamav-milter/milter.sock=

That was altered at first by you, or something in your server.
Let me know if you have other problems

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Busta
-{ D.O.N.A.T.O.R. }-


Joined: 13 Aug 2007
Posts: 81

PostPosted: Wed Feb 20, 2008 9:09 pm    Post subject: Reply with quote

thats weird - after reboot (init 6) milter.sock is set back to the previous state.

srwxr-xr-x 1 clamav clamav 0 2008-02-20 08:53 milter.sock=

I am using the updated kernel- don't think its relevant.

2.6.24.2-smp #1 SMP Sun Feb 17 14:06:06 EET 2008 i686 Intel

Have not made any changes to clamav, except update def's
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1742
Location: Greece

PostPosted: Wed Feb 20, 2008 10:09 pm    Post subject: Reply with quote

I'm using 2.6.24.2-smp too on my devel machine, that's irrelevant

Have you changed any of the init cripts (rc.clamav rc.postfix-milter)?
Did you change the lines in rc.local
rc.postfix-milter must run after rc.clamav
cause if you look at rc.postfix-milter there is a line that says
chmod 777 $milter_socket 1> /dev/null 2> /dev/null


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Busta
-{ D.O.N.A.T.O.R. }-


Joined: 13 Aug 2007
Posts: 81

PostPosted: Wed Feb 20, 2008 10:46 pm    Post subject: Reply with quote

No - rc.postfix-milter runs after rc.clamav in rc.local as it should
have not made any changes to startup scripts

I can manually stop/start rc.clamav and its modifies prems, then stop/start rc.postfix and it correctly changes the perms back.

I will keep digging on this one.

thx's
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1742
Location: Greece

PostPosted: Wed Feb 20, 2008 10:59 pm    Post subject: Reply with quote

If rc.clamav makes the problem then add after

Code:
clamav_start_process "the ClamAV milter"                        \
                "/usr/sbin/clamav-milter --external
                        --quiet --dont-scan-on-error --local --max-children=2
                        --pidfile=/var/run/clamav-milter/milter.pid
                        local:/var/run/clamav-milter/milter.sock"       \
                        "milter" ||return 0


the lines
Code:
sleep 2
milter_sock=/var/run/clamav-milter/milter.sock
chmod 777 $milter_sock 1> /dev/null 2> /dev/null


and berore '}'

to have

Code:
clamav_start_process "the ClamAV milter"                        \
                "/usr/sbin/clamav-milter --external
                        --quiet --dont-scan-on-error --local --max-children=2
                        --pidfile=/var/run/clamav-milter/milter.pid
                        local:/var/run/clamav-milter/milter.sock"       \
                        "milter" ||return 0
                        sleep 2
milter_sock=/var/run/clamav-milter/milter.sock
chmod 777 $milter_sock 1> /dev/null 2> /dev/null
}


That should fix the permission issue.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » Bugs All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional