Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
vsftp not sending welcome message? Goto page Previous  1, 2
View previous topic :: View next topic  
Author Message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 1:35 pm    Post subject: Reply with quote

Port 21 will do.
Have you disable your router's 21port if it has it enabled?
You can try http://net2ftp.com/ to check your ftp from outside, since checking from inside not always work, unless you have somebody from an external network testing your ftp.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 2:42 pm    Post subject: Reply with quote

..but I also tried to make the SMS server an exposed host (Open to the internet) and that did not change anything. Could be that my internal PCs are blocked but my windows firewall allows FTP?
My PC is found at lsoathome.dyndns.org in case you want to try it out from your PC.
Back to top
View user's profile Send private message
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 2:45 pm    Post subject: Reply with quote

I tried net2ftp but could not connect
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 2:48 pm    Post subject: Reply with quote

All your ports are filtered, meaning there is a firewall blocking them...
Either your port forward is not working or you might have an extra protection from your ISP through ports 0-1000.
Try port forward port 35665 to 21in your local machine and try to login from outside at
lsoathome.dyndns.org:35665

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 5:14 pm    Post subject: Reply with quote

I had hooked my SMS server up to a wireless repeater - now it is attached directly to the router and teh WEB server is seen from the outside - still no luck with the FTP server
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 6:44 pm    Post subject: Reply with quote

This is the result of nmap

Code:
PORT   STATE    SERVICE
21/tcp filtered ftp


filtered = firewall or no port forward
open = port forward is enabled, got respond from ftp server
closed = port forward is enabled but ftp service is down

You need to check your router's firewall.
What's your router? I'm guessing a fritzbox ?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Fri Feb 24, 2012 8:00 pm    Post subject: Reply with quote

correct!
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Feb 24, 2012 8:31 pm    Post subject: Reply with quote

I'm guessing all fritzbox are little bit the same, so go to
System and enable expert mode , if it's not enabled and then
Internet -> Port Forward

Have you try to restart router, just in case?
Also have you tried a higher port number as I suggest in previous posts e.g. 55000->21?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Sat Feb 25, 2012 1:23 am    Post subject: Reply with quote

I always work in expert mode Wink

I rebooted server and router and now net2ftp connects correctly and my server is seen from the outside as well.

21/tcp open ftp vsftpd 2.0.8 or later
80/tcp open http Apache httpd 2.2.21 ((Unix) mod_ssl/2.2.21 OpenSSL/0.9.8r DAV/2 PHP/5.3.Cool

Thanks a lot for all your time, support and patience - I learned a lot!
Back to top
View user's profile Send private message
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Sat Feb 25, 2012 7:32 pm    Post subject: Reply with quote

very strange.
Today server and FTP is not available from the outside - I can ping lsoathome.dyndns.org but time out on the server as http and FTP
This is driving me crazy Mad
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Sat Feb 25, 2012 7:53 pm    Post subject: Reply with quote

Port forward is enabled as I can see,but service is down unless this is not you.

Code:
PORT     STATE  SERVICE
21/tcp   closed ftp
22/tcp   closed ssh
8082/tcp closed blackice-alerts


Is you local IP static on SMS machine?
Is dyndns.org service updated?
You can additionally setup ddclient as sometimes there is a delay from routers or not working at all, although fritzboxs as far as I know they work.

Do a
Code:
dig lsoathome.dyndns.org

to check dns is right.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Sat Feb 25, 2012 10:29 pm    Post subject: Reply with quote

I have ddclient running on the SMS server and checking with the DYNDNS homepage it updates the IP address as needed. The SMS server has a static IP address internally in order to assign open ports to it.

I did a DIG and Question/Answer gave me the external IP address

I am now using a good old Belkin router where I have opened the HTTP and FTP ports for the SMS server but the result is the same so seems the issue is in the SMS server
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Sat Feb 25, 2012 10:44 pm    Post subject: Reply with quote

If server is accessible from local network, I don't think SMS has an issue, unless fail2ban ban your external visitors.
You can try to stop fail2ban or restart it and check again.

You can check
iptables -L
to see if there is something blocked.

Do you have uPnP enabled or DMZ option in your router to try it?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
riteman
Member


Joined: 01 Feb 2011
Posts: 27

PostPosted: Wed Feb 29, 2012 1:01 am    Post subject: Reply with quote

The problem was approximately 80 cm in front of the PC: I had opened the ports using the wrong IP address: ...102 instead of ...103 (the server has been given the iP .103 mapped with its MAC-address
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional