Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » Installation Support

Post new topic   Reply to topic
C compiler error?
View previous topic :: View next topic  
Author Message
OneMixDJ
Junior Member


Joined: 02 Nov 2010
Posts: 7

PostPosted: Wed Oct 05, 2011 3:47 pm    Post subject: C compiler error? Reply with quote

Greetings,

While trying to install suggested modules in Webmin, I get errors that suggest that I need a C compiler; which is "new territory" for me. Very Happy

As per the provided snapshots, I get an error that suggests that I do not have a compiler installed. Please also not that in my attempts, I used Make, Test, & Install by default.

Any help and/or guidance is appreciated.

Thanks!



Net-SSLeay-err.PNG
 Description:
Failed attempt on Net::SSLeay
 Filesize:  13.47 KB
 Viewed:  590 Time(s)

Net-SSLeay-err.PNG



Authen-Libwrap-Err.PNG
 Description:
Authen::Libwrap error
 Filesize:  37.85 KB
 Viewed:  589 Time(s)

Authen-Libwrap-Err.PNG



perl-modules.PNG
 Description:
Suggest modules attempted
 Filesize:  30.48 KB
 Viewed:  596 Time(s)

perl-modules.PNG


Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Wed Oct 05, 2011 5:19 pm    Post subject: Reply with quote

All suggested modules are pre-installed in SMS, so if you upgrade from an older version, install perl-modules package as well.

If you want to install gcc use slapt-get and do

Code:
slapt-get -u
slapt-get -i gcc


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
OneMixDJ
Junior Member


Joined: 02 Nov 2010
Posts: 7

PostPosted: Wed Oct 05, 2011 11:23 pm    Post subject: Reply with quote

Greetings gerasimos_h:

I have gcc installed and updated, but I still get the same error.

I performed a reboot, but that didn't change anything either.

Sorry, but I am learning this "on the fly", so I don't know why it doesn't work.

From reading some of the details, it appears that pre-requisite Test::Exception is required. However, I'm not able to install that either:

I've attached the error details in TXT file; hope it's not too painful.
Confused

Thanks again!



test-exception-install_err.txt
 Description:
Test::Exception error details

Download
 Filename:  test-exception-install_err.txt
 Filesize:  9.85 KB
 Downloaded:  748 Time(s)

Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Thu Oct 06, 2011 5:24 am    Post subject: Reply with quote

Quote:
Warning: prerequisite Sub::Uplevel 0.18 not found.


So you need Sub::Uplevel for Test::Exception.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » Installation Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional