Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
authentication failure
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue May 03, 2011 6:35 pm    Post subject: authentication failure Reply with quote

I am trying to use my droid to reply to mail msgs. I can receive but when I try to send one I get authentication failed. I looked at server 'var/log/maillog' and here is the msg:

warning: SASL authentication failure: Could not open /etc/sasldb2: gdbm_errno=3

I am trying to understand what is failing here. If you have any thoughts it would be appreciated.

thanks
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Tue May 03, 2011 8:13 pm    Post subject: Reply with quote

Do you have an smtpd.conf at /etc/postfix or /usr/lib/sasl2 ?

Try to add one with
Code:
mech_list: plain login
pwcheck_method: saslauthd



gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue May 03, 2011 8:24 pm    Post subject: Reply with quote

thanks. will give it a try. I found a similar post on linuxusers.org but was not sure if it would work.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Tue May 03, 2011 8:37 pm    Post subject: Reply with quote

well I tried that but now get the following:

connect from 123.sub-97-215-58.myvzw.com[97.215.58.123]
May 3 11:36:21 ns1 postfix/smtpd[23632]: warning: SASL authentication failure: Could not open /etc/sasldb2: gdbm_errno=3
May 3 11:36:21 ns1 postfix/smtpd[23632]: warning: SASL authentication failure: Could not open /etc/sasldb2: gdbm_errno=3
May 3 11:36:21 ns1 postfix/smtpd[23632]: warning: SASL authentication failure: no secret in database
May 3 11:36:21 ns1 postfix/smtpd[23632]: warning: 123.sub-97-215-58.myvzw.com[97.215.58.123]: SASL CRAM-MD5 authentication failed: authentication failure
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Tue May 03, 2011 10:24 pm    Post subject: Reply with quote

You have to force sasl to use plain or login.
Is this only from your droid phone or do you have problems from all clients?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Wed May 04, 2011 3:22 pm    Post subject: Reply with quote

I've only noticed the msg from when I use the droid.
Back to top
View user's profile Send private message
keopp
Senior Member


Joined: 08 Nov 2008
Posts: 160
Location: Romania

PostPosted: Fri May 06, 2011 6:02 am    Post subject: Reply with quote

Hi there.

I also had troubles sending mail from my Android, the embedded email client do not provide the "PLAIN" authentication method.

Use the K9 email client instead. I found it also more configurabile that the original one(ie. working different signatures for different accounts).


A hint solving your problem is that when tryed to send emails with the original client as a local IP client you get the auth errorrs. If you try to send from an external IP (ie. your GPRS provider) the message is sent. I haven't yet time enough to properly examine this issue so I switced to K9.
Back to top
View user's profile Send private message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Fri May 06, 2011 3:07 pm    Post subject: Reply with quote

thanks keopp! will look into it.
Back to top
View user's profile Send private message
keopp
Senior Member


Joined: 08 Nov 2008
Posts: 160
Location: Romania

PostPosted: Sat May 07, 2011 7:48 pm    Post subject: Reply with quote

Is there any problem with this forum engine???

I didn' t receive email notification about baboo's reply. Nor about SMS-1.6.0 release.

For me isn't a real problem since I check the forum at least 3 times/week.... Wink
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1752
Location: Greece

PostPosted: Sun May 08, 2011 12:28 am    Post subject: Reply with quote

keopp wrote:
Is there any problem with this forum engine???

I didn' t receive email notification about baboo's reply. Nor about SMS-1.6.0 release.

Try to disable email notification and enable it again on your profile...
I had enabled a script sending mail notifications about spammers, I don't know if that causing overload.

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
keopp
Senior Member


Joined: 08 Nov 2008
Posts: 160
Location: Romania

PostPosted: Sun May 08, 2011 6:36 am    Post subject: Reply with quote

Thank you. It seems ok now. For this reply I received notification.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional