Log inUsernamePassword
Log me on automatically each visit    
Register
Register
Log in to check your private messages
Log in to check your private messages
SMS Forum Index » SMS User Support

Post new topic   Reply to topic
gem errors
View previous topic :: View next topic  
Author Message
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Sep 23, 2010 8:01 pm    Post subject: gem errors Reply with quote

I am trying to install a ruby on rails app. When I try to update gem, I get the following error:


Updating installed gems
Updating actionmailer
ERROR: While executing gem ... (Gem::InstallError)
activemodel requires RubyGems version > 1.3.1

But 'gem -v' gives 1.3.1. So, am I doing something wrong here? This is on test server 1.5.3 64bit.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Thu Sep 23, 2010 8:32 pm    Post subject: Reply with quote

What app you try to install?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Sep 23, 2010 9:12 pm    Post subject: Reply with quote

moo-1.1.tar.gz
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Thu Sep 23, 2010 9:25 pm    Post subject: Reply with quote

Do you have a link?

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Thu Sep 23, 2010 9:33 pm    Post subject: Reply with quote

http://mangled.me/blog/moo/

I didn't mean for you to get so involved. I thought that maybe it was a simple config error.
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Sep 24, 2010 6:05 am    Post subject: Reply with quote

Where exactly you get this error?
The only error I got was
Code:
Please switch to Ruby 1.9's standard CSV library.  It's FasterCSV plus
support for Ruby 1.9's m17n encoding engine
.
On a clean system I had to install those gems
Code:
actionmailer (2.2.2)
actionpack (2.2.2)
activerecord (2.2.2)
activeresource (2.2.2)
activesupport (2.2.2)
calendar_date_select (1.16.1)
fastercsv (1.5.3)
mocha (0.9.8)
rails (2.2.2)
rake (0.8.7)
ruby-openid (2.1.8)
test-unit (2.1.1)


gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Fri Sep 24, 2010 3:20 pm    Post subject: Reply with quote

on my server, right after I ran ./configure.

will try clean install and see what happens. Did you try on sms64 or 32?
Back to top
View user's profile Send private message
gerasimos_h
Site Admin


Joined: 09 Aug 2007
Posts: 1753
Location: Greece

PostPosted: Fri Sep 24, 2010 4:14 pm    Post subject: Reply with quote

I test it on SMS64 but you can't run configure.
moo-1.1.tar.gz tree file list is
Code:
README
Rakefile
app/
config/
db/
doc/
lib/
log/
public/
script/
test/
tmp/
vendor/


Install rails with gem
"gem install rails -v 2.2.2"
and install dependencies with rake.
"rake gems:install"
First run "gem update --system" and will upgrade gem to 1.3.7 and after run "gem update"

gerasimos_h

_________________
Superb! Mini Server Project Manager
http://sms.it-ccs.com
Back to top
View user's profile Send private message Visit poster's website
baboo
Senior Member


Joined: 04 Sep 2007
Posts: 676

PostPosted: Fri Sep 24, 2010 4:27 pm    Post subject: Reply with quote

sorry about the post. I was testing a couple of apps and said the wrong thing. I did run rake gems:install and that was when the message error appeared.

I will follow your guide and re-install.

thanks for the help
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SMS Forum Index » SMS User Support All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

SMS - Superb! Mini Server Project © 2016
Powered by phpBB © 2001, 2002 phpBB Group
iCGstation v1.0 Template By Ray © 2003, 2004 iOptional